To export one or more sequences to GenVision:

  1. Either make a selection in the Linear, Circular, or Sequence views, or select a sequence in the Project window.
  1. Choose File > Export as GenVision Project and click the Begin Processing button.

The Export to GenVision dialog compares the features lists for all of the sequences you selected in the Project window in order to find features with the same name that occur in more than one sequence. Once the process is complete, a message will be displayed giving the number of features SeqBuilder Pro identified that occur in more than one of the selected sequences. The table at the bottom of the window lists the number of matches for each feature type, and how many sequences contain a matched feature of the given type.

  1. (optional) To exclude certain feature types from the export, remove the checkmark from the row beside that feature type. If a feature type has 100 or more matches, it will be un-selected by default.
  1. Click the Save Files button.

One GenVision project (.gnv) will be created for each of the selected sequences, and will display the features from one sequence connecting to the same features in all of the other sequences where it occurs. A .txt file will also be created for each exported panel. A new folder containing the exported text files will be created within the same directory as your GenVision project and will be named the same as your GenVision project with a .data extension.


Considerations when exporting sequences from the Project window:

  • The use of color in the resulting GenVision project differs based on whether one feature type or multiple feature types were exported. For a single type, each matching set of features will have its own color. When multiple types are exported, each feature type will have its own color.
  • Two text panels are created for the feature names. One panel displays the feature names as radial text around the outside of the circular image and the other panel displays the feature names in an arc inside the circular image. By default, only the radially displayed text panel is displayed. However, you may display the other text panel if you wish by adjusting its priority within its data file.
  • In the exported image, features are sorted so that feature types that have the most features appear near the center of the circle.


Considerations when exporting sequences from the Linear, Circular, or Sequence views:

  • When exporting from the Circular view, the GenVision figure will be exported as circular. When exporting from the Linear or Sequence view, the GenVision figure will be exported as linear. Protein sequences are exported as linear.
  • The colors for fonts, ORFs, features, and the Circular map title are chosen in the Style panel, and are preserved during export. For features, the Fill color is used for the feature color in GenVision. If a feature does not use the fill color (e.g., stroked shapes), then the line color is used. Unchecking the Fill checkbox will also cause the line color to be used. Feature labels are exported in the same color as the Shape.
  • For linear images, the Vertical value in the Page Layout dialog is used for the “Pages High” GenVision parameter.
  • The page size and margin settings specified in the Page Setup dialog will be preserved in the exported GenVision project.
  • An End Legend file is created for all of the panels within the export, and is named the same as your GenVision project with “_table” appended. For example, GenVisionProject_table.txt.
  • All exported text files will be prefixed with SB to denote that they were exported from SeqBuilder Pro.


Considerations regarding features:

  • Features are grouped into panels by feature type. One panel is created for each feature type.
  • For each feature panel created, a corresponding panel is created for the feature labels. Feature labels are exported to GenVision if the Label Position is either Above or Below. Labels are not exported if position is Inside. For additional information, see The Style Panel.
  • If your features have detached labels, note that the label settings found in Format > Horizontal Labels or Format > Radial Labels (for the Circular view and Format > Horizontal Labels or Format > Vertical Labels (for the Linear view) are used when exporting feature labels to GenVision.
  • Features in SeqBuilder Pro that have the Fill checkbox checked in the Style panel will be exported to GenVision as a filled arrow. When the Fill checkbox is not checked, the feature will be exported as an open arrow.
  • For protein sequences, the export does not include segment names for multi-segmented features.

Need more help with this?
Contact DNASTAR

Thanks for your feedback.